Sunday, May 20News That Matters

Researchers have found a vulnerability in two popular email encryption protocols


European security researchers have found an alarming new vulnerability in the most common forms of email encryption. The attack, described in a report published Monday morning, lets bad actors inject malicious code into intercepted emails, despite encryption protocols designed to protect against code injection. Implemented correctly, the malicious code could be used to steal the entire contents of a target’s inbox.

The vulnerability affects two of the most common email encryption protocols, PGP and S/MIME, although the degree of vulnerability depends heavily on the client’s implementation of the protocol. A number of different clients are vulnerable, including Apple Mail, the Mail App on iOS, and Thunderbird. Notably, many currently available message authentication systems can effectively block the attack.

If an email encrypted using those clients is intercepted in transit, an attacker could use the new vulnerability modify the email, adding malicious HTML code before sending it to the target. When the target opens the new email, the malicious code could be used to send back the plaintext of the email.

Many corporate servers still use S/MIME encryption, so the attack poses a significant risk to current systems.

In practical terms, however, the lesson is this: there is no such thing as a ‘theoretical vulnerability’. There are exploitable vulnerabilities, and vulnerabilities that haven’t been exploited yet. We need to build systems like we recognize this. 16/16

— Matthew Green (@matthew_d_green) May 14, 2018

The open-sourced software GNU Privacy Guard wrote in a statement, “There are two ways to mitigate this attack: Don’t use HTML emails…use authenticated encryption.”

Sebastian Schinzel, a professor of Computer Security at the Münster University of Applied Sciences‏ who co-wrote the paper warns on Twitter that “there are currently no reliable fixes for the vulnerability.” He recommends people disable their encryption in their email client if they use PGP for sensitive communications. The Electronic Frontier Foundation calls these measures “a temporary, conservative stopgap” until the wider community fixes the issues.

Let’s block ads! (Why?)





Source link

Leave a Reply